Erstellt von - Uhr

IT-Sicherheit: UNIX gefährdet - Update für IT-Sicherheitswarnung zu Tinyproxy (Risiko: kritisch)

Für Tinyproxy wurde ein Update zur IT-Sicherheitswarnung einer bekannten Schwachstelle veröffentlicht. Wie sich betroffene Nutzer verhalten sollten, erfahren Sie hier.

Aktuelle IT-Sicherheitshinweise auf news.de (Symbolbild). (Foto) Suche
Aktuelle IT-Sicherheitshinweise auf news.de (Symbolbild). Bild: picture alliance / dpa | Jana Pape

Das Bundesamt für Sicherheit in der Informationstechnik (BSI) hat am 05.06.2024 ein Update zu einer am 01.05.2024 bekanntgewordenen kritischen Sicherheitslücke mit mehreren Schwachstellen für Tinyproxy herausgegeben. Betroffen von der Sicherheitslücke sind das Betriebssystem UNIX sowie die Produkte Debian Linux, SUSE openSUSE und Open Source Tinyproxy.

Die neuesten Hersteller-Empfehlungen bezüglich Updates, Workarounds und Sicherheitspatches für diese Sicherheitslücke finden Sie hier: Debian Security Advisory DSA-5705 (Stand: 05.06.2024). Weitere nützliche Links werden weiter unten in diesem Artikel aufgeführt.

Sicherheitshinweis für Tinyproxy - Kritisches Risiko

Risikostufe: 4 (kritisch)
CVSS Base Score: 9,8
CVSS Temporal Score: 9,0
Remoteangriff: Ja

Zur Einschätzung des Schweregrads von Schwachstellen in Computersystemen wird das Common Vulnerability Scoring System (CVSS) angewandt. Der CVSS-Standard ermöglicht es, potenzielle oder tatsächliche Sicherheitslücken auf Basis verschiedener Metriken miteinander zu vergleichen, um eine darauf aufbauende Prioritätenliste zur Einleitung von Gegenmaßnahmen zu erstellen. Für die Schweregrade einer Schwachstelle werden die Attribute "keine", "niedrig", "mittel", "hoch" und "kritisch" verwendet. Der Base Score bewertet die Voraussetzungen für einen Angriff (u.a. Authentifizierung, Komplexität, Privilegien, Userinteraktion) sowie dessen Konsequenzen. Beim Temporal Score fließen über die Zeit veränderbare Rahmenbedingungen in die Bewertung ein. Der Schweregrad der aktuellen Schwachstelle wird nach dem CVSS mit einem Base Score von 9,8 als "kritisch" eingeschätzt.

Tinyproxy Bug: Zusammenfassung der bekannten Schwachstellen

Tinyproxy ist ein HTTP/HTTPS-Proxy-Daemon für POSIX-Betriebssysteme.

Ein entfernter, anonymer Angreifer kann mehrere Schwachstellen in Tinyproxy ausnutzen, um beliebigen Programmcode auszuführen und um vertrauliche Informationen offenzulegen.

Klassifiziert wurden die Schwachstellen mithilfe des CVE-Referenziersystems (Common Vulnerabilities and Exposures) durch die individuellen Seriennummern CVE-2023-49606 und CVE-2023-40533.

Von der Tinyproxy-Sicherheitslücke betroffene Systeme im Überblick

Betriebssystem
UNIX

Produkte
Debian Linux (cpe:/o:debian:debian_linux)
SUSE openSUSE (cpe:/o:suse:opensuse)
Open Source Tinyproxy <=1.11.1 (cpe:/a:tinyproxy_project:tinyproxy)
Open Source Tinyproxy <=1.10.0. (cpe:/a:tinyproxy_project:tinyproxy)

Allgemeine Maßnahmen zum Umgang mit IT-Sicherheitslücken

  1. Anwender der betroffenen Anwendungen sollten diese auf dem aktuellsten Stand halten. Hersteller sind bei Bekanntwerden von Sicherheitslücken dazu angehalten, diese schnellstmöglich durch Entwicklung eines Patches oder eines Workarounds zu beheben. Sollten Sicherheitspatches verfügbar sein, installieren Sie diese zeitnah.
  2. Konsultieren Sie zu Informationszwecken die im nächsten Abschnitt aufgeführten Quellen. Häufig enthalten diese weiterführende Informationen zur aktuellsten Version der betreffenden Software sowie zur Verfügbarkeit von Sicherheitspatches oder Hinweise zu Workarounds.
  3. Wenden Sie sich bei weiteren Fragen oder Unsicherheiten an Ihren zuständigen Administrator. IT-Sicherheitsverantwortliche sollten regelmäßig prüfen, wann das herstellende Unternehmen ein neues Sicherheitsupdate zur Verfügung stellt.

Quellen zu Updates, Patches und Workarounds

An dieser Stelle finden Sie weiterführende Links mit Informationen über Bug-Reports, Security-Fixes und Workarounds.

Debian Security Advisory DSA-5705 vom 2024-06-05 (05.06.2024)
Weitere Informationen finden Sie unter: https://lists.debian.org/debian-security-announce/2024/msg00115.html

openSUSE Security Update OPENSUSE-SU-2024:0119-1 vom 2024-05-10 (12.05.2024)
Weitere Informationen finden Sie unter: https://lists.opensuse.org/archives/list/security-announce@lists.opensuse.org/message/OM62U7F2OTTTTR4PTM6RV3UAOCUHRC75/

NIST Vulnerability Database vom 2024-05-01 (01.05.2024)
Weitere Informationen finden Sie unter: https://nvd.nist.gov/vuln/detail/CVE-2023-49606

NIST Vulnerability Database vom 2024-05-01 (01.05.2024)
Weitere Informationen finden Sie unter: https://nvd.nist.gov/vuln/detail/CVE-2023-40533

GitHub Advisory Database vom 2024-05-01 (01.05.2024)
Weitere Informationen finden Sie unter: https://github.com/advisories/GHSA-w78j-vw2g-233v

GitHub Advisory Database vom 2024-05-01 (01.05.2024)
Weitere Informationen finden Sie unter: https://github.com/advisories/GHSA-qc4p-7g72-jqrq

Versionshistorie dieser Sicherheitswarnung

Dies ist die 3. Version des vorliegenden IT-Sicherheitshinweises für Tinyproxy. Sollten weitere Updates bekanntgegeben werden, wird dieser Text aktualisiert. Änderungen oder Ergänzungen können Sie in dieser Versionshistorie nachlesen.

01.05.2024 - Initiale Fassung
12.05.2024 - Neue Updates von openSUSE aufgenommen
05.06.2024 - Neue Updates von Debian aufgenommen

+++ Redaktioneller Hinweis: Dieser Text wurde auf Basis aktueller BSI-Daten generiert und wird je nach Warnlage datengetrieben aktualisiert. Feedback und Anmerkungen nehmen wir unter hinweis@news.de entgegen. +++

Folgen Sie News.de schon bei Facebook, Twitter, Pinterest und YouTube? Hier finden Sie brandheiße News, aktuelle Videos und den direkten Draht zur Redaktion.

/roj/news.de

Themen:
Bleiben Sie dran!

Wollen Sie wissen, wie das Thema weitergeht? Wir informieren Sie gerne.