Erstellt von - Uhr

Ruby: Update für IT-Sicherheitswarnung (Risiko: hoch)

Eine für Ruby herausgegebene Sicherheitswarnung hat vom BSI ein Update erhalten. Wie sich betroffene Anwender verhalten sollten, erfahren Sie hier.

Aktuelle IT-Sicherheitshinweise auf news.de (Symbolbild). (Foto) Suche
Aktuelle IT-Sicherheitshinweise auf news.de (Symbolbild). Bild: picture alliance/dpa | Oliver Berg

Das Bundesamt für Sicherheit in der Informationstechnik (BSI) hat am 11.06.2024 ein Update zu einer am 20.03.2024 bekanntgewordenen Sicherheitslücke mit mehreren Schwachstellen für Ruby herausgegeben. Betroffen von der Sicherheitslücke sind die Betriebssysteme Linux, UNIX und Windows sowie die Produkte Open Source Ruby, Debian Linux, Red Hat Enterprise Linux, Fedora Linux und Oracle Linux.

Die neuesten Hersteller-Empfehlungen bezüglich Updates, Workarounds und Sicherheitspatches für diese Sicherheitslücke finden Sie hier: Red Hat Security Advisory RHSA-2024:3838 (Stand: 12.06.2024). Weitere nützliche Quellen werden weiter unten in diesem Artikel aufgeführt.

Mehrere Schwachstellen für Ruby - Risiko: hoch

Risikostufe: 4 (hoch)
CVSS Base Score: 9,8
CVSS Temporal Score: 8,5
Remoteangriff: Ja

Zur Bewertung des Schweregrads von Sicherheitsanfälligkeiten in Computersystemen wird das Common Vulnerability Scoring System (CVSS) angewandt. Der CVSS-Standard ermöglicht es, potenzielle oder tatsächliche Sicherheitslücken auf Basis verschiedener Kriterien miteinander zu vergleichen, um Gegenmaßnahmen besser priorisieren zu können. Für die Schweregrade einer Schwachstelle werden die Attribute "keine", "niedrig", "mittel", "hoch" und "kritisch" verwendet. Der Base Score bewertet die Voraussetzungen für einen Angriff (u.a. Authentifizierung, Komplexität, Privilegien, Userinteraktion) sowie dessen Konsequenzen. Der Temporal Score berücksichtigt darüber hinaus zeitliche Veränderungen hinsichtlich der Gefahrenlage. Die Gefährdung der aktuellen Schwachstelle wird nach dem CVSS mit einem Base Score von 9,8 als "hoch" eingeschätzt.

Ruby Bug: Zusammenfassung der bekannten Schwachstellen

Ruby ist eine interpretierte, objektorientierte Skriptsprache.

Ein Angreifer kann mehrere Schwachstellen in Ruby ausnutzen, um Informationen offenzulegen oder Code auszuführen.

Klassifiziert wurden die Schwachstellen mithilfe des CVE-Bezeichnungssystems (Common Vulnerabilities and Exposures) durch die individuellen Seriennummern CVE-2024-27280 und CVE-2024-27281.

Von der Ruby-Sicherheitslücke betroffene Systeme im Überblick

Betriebssysteme
Linux, UNIX, Windows

Produkte
Open Source Ruby <=3.1.4 (cpe:/a:ruby-lang:ruby)
Debian Linux (cpe:/o:debian:debian_linux)
Red Hat Enterprise Linux (cpe:/o:redhat:enterprise_linux)
Fedora Linux (cpe:/o:fedoraproject:fedora)
Oracle Linux (cpe:/o:oracle:linux)
Open Source Ruby <=3.0.6 (cpe:/a:ruby-lang:ruby)
Open Source Ruby <=3.2.3 (cpe:/a:ruby-lang:ruby)
Open Source Ruby <=3.3.0 (cpe:/a:ruby-lang:ruby)

Allgemeine Maßnahmen zum Umgang mit IT-Sicherheitslücken

  1. Anwender der betroffenen Anwendungen sollten diese auf dem aktuellsten Stand halten. Hersteller sind bei Bekanntwerden von Sicherheitslücken dazu angehalten, diese schnellstmöglich durch Entwicklung eines Patches oder eines Workarounds zu beheben. Sollten Sicherheitspatches verfügbar sein, installieren Sie diese zeitnah.
  2. Konsultieren Sie zu Informationszwecken die im nächsten Abschnitt aufgeführten Quellen. Häufig enthalten diese weiterführende Informationen zur aktuellsten Version der betreffenden Software sowie zur Verfügbarkeit von Sicherheitspatches oder Hinweise zu Workarounds.
  3. Wenden Sie sich bei weiteren Fragen oder Unsicherheiten an Ihren zuständigen Administrator. IT-Sicherheitsverantwortliche sollten die genannten Quellen regelmäßig daraufhin prüfen, ob ein neues Sicherheitsupdate zur Verfügung steht.

Quellen zu Updates, Patches und Workarounds

An dieser Stelle finden Sie weiterführende Links mit Informationen über Bug-Reports, Security-Fixes und Workarounds.

Red Hat Security Advisory RHSA-2024:3838 vom 2024-06-12 (11.06.2024)
Weitere Informationen finden Sie unter: https://access.redhat.com/errata/RHSA-2024:3838

Oracle Linux Security Advisory ELSA-2024-3670 vom 2024-06-11 (10.06.2024)
Weitere Informationen finden Sie unter: https://linux.oracle.com/errata/ELSA-2024-3670.html

Oracle Linux Security Advisory ELSA-2024-3671 vom 2024-06-07 (06.06.2024)
Weitere Informationen finden Sie unter: https://linux.oracle.com/errata/ELSA-2024-3671.html

Oracle Linux Security Advisory ELSA-2024-3668 vom 2024-06-07 (06.06.2024)
Weitere Informationen finden Sie unter: https://linux.oracle.com/errata/ELSA-2024-3668.html

Red Hat Security Advisory RHSA-2024:3670 vom 2024-06-06 (05.06.2024)
Weitere Informationen finden Sie unter: https://access.redhat.com/errata/RHSA-2024:3670

Red Hat Security Advisory RHSA-2024:3671 vom 2024-06-06 (05.06.2024)
Weitere Informationen finden Sie unter: https://access.redhat.com/errata/RHSA-2024:3671

Red Hat Security Advisory RHSA-2024:3668 vom 2024-06-06 (05.06.2024)
Weitere Informationen finden Sie unter: https://access.redhat.com/errata/RHSA-2024:3668

Oracle Linux Security Advisory ELSA-2024-3546 vom 2024-06-03 (03.06.2024)
Weitere Informationen finden Sie unter: https://linux.oracle.com/errata/ELSA-2024-3546.html

Oracle Linux Security Advisory ELSA-2024-3500 vom 2024-06-01 (02.06.2024)
Weitere Informationen finden Sie unter: https://linux.oracle.com/errata/ELSA-2024-3500.html

Red Hat Security Advisory RHSA-2024:3546 vom 2024-06-03 (02.06.2024)
Weitere Informationen finden Sie unter: https://access.redhat.com/errata/RHSA-2024:3546

Red Hat Security Advisory RHSA-2024:3500 vom 2024-05-30 (30.05.2024)
Weitere Informationen finden Sie unter: https://access.redhat.com/errata/RHSA-2024:3500

Debian Security Advisory DSA-5677 vom 2024-05-03 (05.05.2024)
Weitere Informationen finden Sie unter: https://lists.debian.org/debian-security-announce/2024/msg00086.html

Fedora Security Advisory FEDORA-2024-31CAC8B8EC vom 2024-04-25 (24.04.2024)
Weitere Informationen finden Sie unter: https://bodhi.fedoraproject.org/updates/FEDORA-2024-31cac8b8ec

Fedora Security Advisory FEDORA-2024-48BDD3ABBF vom 2024-04-25 (24.04.2024)
Weitere Informationen finden Sie unter: https://bodhi.fedoraproject.org/updates/FEDORA-2024-48bdd3abbf

Fedora Security Advisory FEDORA-2024-14DB7B21A2 vom 2024-04-24 (24.04.2024)
Weitere Informationen finden Sie unter: https://bodhi.fedoraproject.org/updates/FEDORA-2024-14db7b21a2

Ruby Advisory vom 2024-03-20 (20.03.2024)
Weitere Informationen finden Sie unter: https://www.ruby-lang.org/en/news/2024/03/21/rce-rdoc-cve-2024-27281/

Ruby Advisory vom 2024-03-20 (20.03.2024)
Weitere Informationen finden Sie unter: https://www.ruby-lang.org/en/news/2024/03/21/buffer-overread-cve-2024-27280/

Versionshistorie dieser Sicherheitswarnung

Dies ist die 10. Version des vorliegenden IT-Sicherheitshinweises für Ruby. Sollten weitere Updates bekanntgegeben werden, wird dieser Text aktualisiert. Änderungen oder Ergänzungen können Sie in dieser Versionshistorie nachlesen.

20.03.2024 - Initiale Fassung
24.04.2024 - Neue Updates von Fedora aufgenommen
05.05.2024 - Neue Updates von Debian aufgenommen
30.05.2024 - Neue Updates von Red Hat aufgenommen
02.06.2024 - Neue Updates von Red Hat und Oracle Linux aufgenommen
03.06.2024 - Neue Updates von Oracle Linux aufgenommen
05.06.2024 - Neue Updates von Red Hat aufgenommen
06.06.2024 - Neue Updates von Oracle Linux aufgenommen
10.06.2024 - Neue Updates von Oracle Linux aufgenommen
11.06.2024 - Neue Updates von Red Hat aufgenommen

+++ Redaktioneller Hinweis: Dieser Text wurde auf Basis aktueller BSI-Daten generiert und wird je nach Warnlage datengetrieben aktualisiert. Feedback und Anmerkungen nehmen wir unter hinweis@news.de entgegen. +++

Folgen Sie News.de schon bei Facebook, Twitter, Pinterest und YouTube? Hier finden Sie brandheiße News, aktuelle Videos und den direkten Draht zur Redaktion.

/roj/news.de

Themen:
Bleiben Sie dran!

Wollen Sie wissen, wie das Thema weitergeht? Wir informieren Sie gerne.