Erstellt von - Uhr

libvirt gefährdet: Schwachstelle ermöglicht Denial of Service

Eine für libvirt herausgegebene Sicherheitswarnung hat vom BSI ein Update erhalten. Wie sich betroffene Anwender verhalten sollten, erfahren Sie hier.

Aktuelle IT-Sicherheitshinweise auf news.de (Symbolbild). (Foto) Suche
Aktuelle IT-Sicherheitshinweise auf news.de (Symbolbild). Bild: picture alliance / dpa | Jana Pape

Das Bundesamt für Sicherheit in der Informationstechnik (BSI) hat am 04.06.2024 ein Update zu einer am 11.03.2024 bekanntgewordenen Sicherheitslücke für libvirt veröffentlicht. Betroffen von der Sicherheitslücke sind das Betriebssystem Linux sowie die Produkte Debian Linux, Amazon Linux 2, Red Hat Enterprise Linux, Fedora Linux, Ubuntu Linux, SUSE Linux, Oracle Linux, EMC Avamar, Open Source libvirt und Dell NetWorker.

Die neuesten Hersteller-Empfehlungen bezüglich Updates, Workarounds und Sicherheitspatches für diese Sicherheitslücke finden Sie hier: Oracle Linux Security Advisory ELSA-2024-12406 (Stand: 04.06.2024). Weitere nützliche Quellen werden weiter unten in diesem Artikel aufgeführt.

Sicherheitshinweis für libvirt - Risiko: mittel

Risikostufe: 3 (mittel)
CVSS Base Score: 5,5
CVSS Temporal Score: 4,8
Remoteangriff: Nein

Zur Bewertung des Schweregrads von Sicherheitsanfälligkeiten in Computersystemen wird das Common Vulnerability Scoring System (CVSS) angewandt. Der CVSS-Standard ermöglicht es, potenzielle oder tatsächliche Sicherheitslücken auf Basis verschiedener Metriken miteinander zu vergleichen, um eine darauf aufbauende Prioritätenliste zur Einleitung von Gegenmaßnahmen zu erstellen. Für die Schweregrade einer Schwachstelle werden die Attribute "keine", "niedrig", "mittel", "hoch" und "kritisch" verwendet. Der Base Score bewertet die Voraussetzungen für einen Angriff (u.a. Authentifizierung, Komplexität, Privilegien, Userinteraktion) sowie dessen Konsequenzen. Der Temporal Score berücksichtigt darüber hinaus zeitliche Veränderungen hinsichtlich der Gefahrenlage. Der Schweregrad der aktuellen Schwachstelle wird nach dem CVSS mit einem Base Score von 5,5 als "mittel" eingeschätzt.

libvirt Bug: Schwachstelle ermöglicht Denial of Service

Libvirt ist eine Bibliothek, die Schnittstellen zu den Virtualisierungsfunktionen von Linux anbietet und Werkzeuge zur Verwaltung von virtualisierten Systemen zur Verfügung stellt.

Ein lokaler Angreifer kann eine Schwachstelle in libvirt ausnutzen, um einen Denial of Service Angriff durchzuführen.

Die Verwundbarkeit wird mit der individuellen CVE-Seriennummer (Common Vulnerabilities and Exposures) CVE-2024-1441 gehandelt.

Von der libvirt-Sicherheitslücke betroffene Systeme im Überblick

Betriebssystem
Linux

Produkte
Debian Linux (cpe:/o:debian:debian_linux)
Amazon Linux 2 (cpe:/o:amazon:linux_2)
Red Hat Enterprise Linux (cpe:/o:redhat:enterprise_linux)
Fedora Linux (cpe:/o:fedoraproject:fedora)
Ubuntu Linux (cpe:/o:canonical:ubuntu_linux)
SUSE Linux (cpe:/o:suse:suse_linux)
Oracle Linux (cpe:/o:oracle:linux)
EMC Avamar (cpe:/a:emc:avamar)
Open Source libvirt <10.1.0 (cpe:/a:redhat:libvirt)
Dell NetWorker virtual (cpe:/a:dell:networker)

Allgemeine Empfehlungen zum Umgang mit IT-Sicherheitslücken

  1. Anwender der betroffenen Anwendungen sollten diese auf dem aktuellsten Stand halten. Hersteller sind bei Bekanntwerden von Sicherheitslücken dazu angehalten, diese schnellstmöglich durch Entwicklung eines Patches oder eines Workarounds zu beheben. Sollten Sicherheitspatches verfügbar sein, installieren Sie diese zeitnah.
  2. Konsultieren Sie zu Informationszwecken die im nächsten Abschnitt aufgeführten Quellen. Häufig enthalten diese weiterführende Informationen zur aktuellsten Version der betreffenden Software sowie zur Verfügbarkeit von Sicherheitspatches oder Hinweise zu Workarounds.
  3. Wenden Sie sich bei weiteren Fragen oder Unsicherheiten an Ihren zuständigen Administrator. IT-Sicherheitsverantwortliche sollten die genannten Quellen regelmäßig daraufhin prüfen, ob ein neues Sicherheitsupdate zur Verfügung steht.

Hersteller-Informationen zu Updates, Patches und Workarounds

An dieser Stelle finden Sie weiterführende Links mit Informationen über Bug-Reports, Security-Fixes und Workarounds.

Oracle Linux Security Advisory ELSA-2024-12406 vom 2024-06-04 (04.06.2024)
Weitere Informationen finden Sie unter: https://linux.oracle.com/errata/ELSA-2024-12406.html

Dell Security Advisory DSA-2024-198 vom 2024-05-08 (07.05.2024)
Weitere Informationen finden Sie unter: https://www.dell.com/support/kbdoc/000224827/dsa-2024-=

Oracle Linux Security Advisory ELSA-2024-2560 vom 2024-05-07 (07.05.2024)
Weitere Informationen finden Sie unter: https://linux.oracle.com/errata/ELSA-2024-2560.html

Red Hat Security Advisory RHSA-2024:2560 vom 2024-04-30 (01.05.2024)
Weitere Informationen finden Sie unter: https://access.redhat.com/errata/RHSA-2024:2560

Ubuntu Security Notice USN-6734-2 vom 2024-04-29 (29.04.2024)
Weitere Informationen finden Sie unter: https://ubuntu.com/security/notices/USN-6734-2

Amazon Linux Security Advisory ALAS-2024-2513 vom 2024-04-18 (17.04.2024)
Weitere Informationen finden Sie unter: https://alas.aws.amazon.com/AL2/ALAS-2024-2513.html

Ubuntu Security Notice USN-6734-1 vom 2024-04-15 (15.04.2024)
Weitere Informationen finden Sie unter: https://ubuntu.com/security/notices/USN-6734-1

Oracle Linux Security Advisory ELSA-2024-12276 vom 2024-04-10 (10.04.2024)
Weitere Informationen finden Sie unter: https://linux.oracle.com/errata/ELSA-2024-12276.html

SUSE Security Update SUSE-SU-2024:1099-1 vom 2024-04-08 (08.04.2024)
Weitere Informationen finden Sie unter: https://lists.suse.com/pipermail/sle-security-updates/2024-April/018297.html

Debian Security Advisory DLA-3778 vom 2024-04-01 (01.04.2024)
Weitere Informationen finden Sie unter: https://lists.debian.org/debian-lts-announce/2024/04/msg00000.html

SUSE Security Update SUSE-SU-2024:1005-1 vom 2024-03-27 (27.03.2024)
Weitere Informationen finden Sie unter: https://lists.suse.com/pipermail/sle-security-updates/2024-March/018225.html

Fedora Security Advisory FEDORA-2024-1A59230214 vom 2024-03-12 (12.03.2024)
Weitere Informationen finden Sie unter: https://bodhi.fedoraproject.org/updates/FEDORA-2024-1a59230214

Fedora Security Advisory FEDORA-2024-D96CDEB8EC vom 2024-03-12 (12.03.2024)
Weitere Informationen finden Sie unter: https://bodhi.fedoraproject.org/updates/FEDORA-2024-d96cdeb8ec

RedHat Customer Portal vom 2024-03-11 (11.03.2024)
Weitere Informationen finden Sie unter: https://access.redhat.com/security/cve/CVE-2024-1441

GitHub Advisory Database vom 2024-03-11 (11.03.2024)
Weitere Informationen finden Sie unter: https://github.com/advisories/GHSA-2cj9-wjmr-5w57

Versionshistorie dieser Sicherheitswarnung

Dies ist die 12. Version des vorliegenden IT-Sicherheitshinweises für libvirt. Sollten weitere Updates bekanntgegeben werden, wird dieser Text aktualisiert. Die vorgenommenen Änderungen können Sie anhand der folgenden Versionshistorie nachvollziehen.

11.03.2024 - Initiale Fassung
12.03.2024 - Neue Updates von Fedora aufgenommen
27.03.2024 - Neue Updates von SUSE aufgenommen
01.04.2024 - Neue Updates von Debian aufgenommen
08.04.2024 - Neue Updates von SUSE aufgenommen
10.04.2024 - Neue Updates von Oracle Linux aufgenommen
15.04.2024 - Neue Updates von Ubuntu aufgenommen
17.04.2024 - Neue Updates von Amazon aufgenommen
29.04.2024 - Neue Updates von Ubuntu aufgenommen
01.05.2024 - Neue Updates von Red Hat aufgenommen
07.05.2024 - Neue Updates von Oracle Linux und Dell aufgenommen
04.06.2024 - Neue Updates von Oracle Linux aufgenommen

+++ Redaktioneller Hinweis: Dieser Text wurde auf Basis aktueller BSI-Daten generiert und wird je nach Warnlage datengetrieben aktualisiert. Feedback und Anmerkungen nehmen wir unter hinweis@news.de entgegen. +++

Folgen Sie News.de schon bei Facebook, Twitter, Pinterest und YouTube? Hier finden Sie brandheiße News, aktuelle Videos und den direkten Draht zur Redaktion.

/roj/news.de

Themen:
Bleiben Sie dran!

Wollen Sie wissen, wie das Thema weitergeht? Wir informieren Sie gerne.