Uhr

Logback gefährdet: IT-Sicherheitslücke mit hohem Risiko! Warnung erhält Update

Wie das BSI meldet, hat die IT-Sicherheitswarnung, welche eine vorliegende Schwachstelle für Logback betrifft, ein Update erhalten. Welche Betriebssysteme und Produkte von der Sicherheitslücke betroffen sind, lesen Sie hier auf news.de.

Aktuelle IT-Sicherheitshinweise auf news.de (Symbolbild). (Foto) Suche
Aktuelle IT-Sicherheitshinweise auf news.de (Symbolbild). Bild: Adobe Stock / Maximusdn

Das Bundesamt für Sicherheit in der Informationstechnik (BSI) hat am 12.01.2024 ein Update zu einer am 04.12.2023 bekanntgewordenen Sicherheitslücke für Logback veröffentlicht. Betroffen von der Sicherheitslücke sind die Betriebssysteme Linux, MacOS X und Windows sowie die Produkte Open Source Logback und VMware Tanzu Spring Cloud.

Die neuesten Hersteller-Empfehlungen bezüglich Updates, Workarounds und Sicherheitspatches für diese Sicherheitslücke finden Sie hier: GitHub Security Advisory GHSA-VMQ6-5M68-F53M (Stand: 12.01.2024). Weitere nützliche Links werden weiter unten in diesem Artikel aufgeführt.

Sicherheitshinweis für Logback - Risiko: hoch

Risikostufe: 3 (hoch)
CVSS Base Score: 8,6
CVSS Temporal Score: 7,5
Remoteangriff: Ja

Zur Einschätzung des Schweregrads von Sicherheitsanfälligkeiten in Computersystemen wird das Common Vulnerability Scoring System (CVSS) angewandt. Der CVSS-Standard ermöglicht es, potenzielle oder tatsächliche Sicherheitslücken auf Basis verschiedener Metriken miteinander zu vergleichen, um eine darauf aufbauende Prioritätenliste zur Einleitung von Gegenmaßnahmen zu erstellen. Für die Schweregrade einer Schwachstelle werden die Attribute "keine", "niedrig", "mittel", "hoch" und "kritisch" verwendet. Der Base Score bewertet die Voraussetzungen für einen Angriff (u.a. Authentifizierung, Komplexität, Privilegien, Userinteraktion) sowie dessen Konsequenzen. Beim Temporal Score fließen über die Zeit veränderbare Rahmenbedingungen in die Bewertung ein. Der Schweregrad der aktuellen Schwachstelle wird nach dem CVSS mit einem Base Score von 8,6 als "hoch" eingeschätzt.

Logback Bug: Schwachstelle ermöglicht Denial of Service

Logback ist der Nachfolger des populären log4j-Projekts und stellt eine Java Logging API zur Verfügung.

Ein entfernter, anonymer Angreifer kann eine Schwachstelle in Logback ausnutzen, um einen Denial-of-Service-Zustand zu erzeugen.

Klassifiziert wurde die Schwachstelle mithilfe des CVE-Bezeichnungssystems (Common Vulnerabilities and Exposures) durch die individuelle Seriennummer CVE-2023-6378.

Von der Logback-Sicherheitslücke betroffene Systeme im Überblick

Betriebssysteme
Linux, MacOS X, Windows

Produkte
Open Source Logback < 1.3.14 (cpe:/a:logback:logback)
Open Source Logback < 1.4.14 (cpe:/a:logback:logback)
VMware Tanzu Spring Cloud Dataflow < 2.11.2 (cpe:/a:vmware_tanzu:spring_cloud)

Allgemeine Empfehlungen zum Umgang mit IT-Schwachstellen

  1. Anwender der betroffenen Systeme sollten diese auf dem aktuellsten Stand halten. Hersteller sind bei Bekanntwerden von Sicherheitslücken dazu angehalten, diese schnellstmöglich durch Entwicklung eines Patches oder eines Workarounds zu beheben. Sollten neue Sicherheitsupdates verfügbar sein, installieren Sie diese zeitnah.
  2. Konsultieren Sie zu Informationszwecken die im nächsten Abschnitt aufgeführten Quellen. Häufig enthalten diese weiterführende Informationen zur aktuellsten Version der betreffenden Software sowie zur Verfügbarkeit von Sicherheitspatches oder Hinweise zu Workarounds.
  3. Wenden Sie sich bei weiteren Fragen oder Unsicherheiten an Ihren zuständigen Administrator. IT-Sicherheitsverantwortliche sollten regelmäßig prüfen, wann der von der IT-Sicherheitswarnung betroffene Hersteller ein neues Sicherheitsupdate zur Verfügung stellt.

Quellen zu Updates, Patches und Workarounds

An dieser Stelle befinden sich weiterführende Links mit Informationen über Bug-Reports, Security-Fixes und Workarounds.

GitHub Security Advisory GHSA-VMQ6-5M68-F53M vom 2024-01-12 (12.01.2024)
Weitere Informationen finden Sie unter: https://spring.io/blog/2024/01/11/spring-cloud-dataflow-2-11-2-released

NIST Vulnerability Database vom 2023-12-03 (04.12.2023)
Weitere Informationen finden Sie unter: https://nvd.nist.gov/vuln/detail/CVE-2023-6378

logback Advisory vom 2023-12-03 (04.12.2023)
Weitere Informationen finden Sie unter: https://mailman.qos.ch/pipermail/announce/2023/000188.html

Versionshistorie dieser Sicherheitswarnung

Dies ist die 2. Version des vorliegenden IT-Sicherheitshinweises für Logback. Sollten weitere Updates bekanntgegeben werden, wird dieser Text aktualisiert. Änderungen oder Ergänzungen können Sie in dieser Versionshistorie nachlesen.

04.12.2023 - Initiale Fassung
12.01.2024 - Neue Updates von Open Source aufgenommen

+++ Redaktioneller Hinweis: Dieser Text wurde auf Basis aktueller BSI-Daten KI-gestützt erstellt. Feedback und Anmerkungen nehmen wir unter hinweis@news.de entgegen. +++

Folgen Sie News.de schon bei Facebook, Twitter, Pinterest und YouTube? Hier finden Sie brandheiße News, aktuelle Videos und den direkten Draht zur Redaktion.

Bearbeitet durch kns

roj/news.de

Themen:
Bleiben Sie dran!

Wollen Sie wissen, wie das Thema weitergeht? Wir informieren Sie gerne.