Uhr

vim gefährdet: Sicherheitswarnung vor mehreren IT-Schwachstellen

Eine für vim herausgegebene Sicherheitswarnung hat vom BSI ein Update erhalten. Was betroffene Nutzer beachten sollten, erfahren Sie hier.

Aktuelle IT-Sicherheitshinweise auf news.de (Symbolbild). (Foto) Suche
Aktuelle IT-Sicherheitshinweise auf news.de (Symbolbild). Bild: picture alliance/dpa | Oliver Berg

Das Bundesamt für Sicherheit in der Informationstechnik (BSI) hat am 09.01.2024 ein Update zu einer am 17.11.2023 bekanntgewordenen Sicherheitslücke mit mehreren Schwachstellen für vim herausgegeben. Betroffen von der Sicherheitslücke sind die Betriebssysteme UNIX, Linux, MacOS X und Windows sowie die Produkte Amazon Linux 2, Fedora Linux, Ubuntu Linux und Open Source vim.

Die neuesten Hersteller-Empfehlungen bezüglich Updates, Workarounds und Sicherheitspatches für diese Sicherheitslücke finden Sie hier: Amazon Linux Security Advisory ALAS-2024-1902 (Stand: 09.01.2024). Weitere nützliche Quellen werden weiter unten in diesem Artikel aufgeführt.

Mehrere Schwachstellen für vim - Risiko: niedrig

Risikostufe: 4 (niedrig)
CVSS Base Score: 3,9
CVSS Temporal Score: 3,4
Remoteangriff: Nein

Zur Einschätzung der Verwundbarkeit von Computersystemen wird das Common Vulnerability Scoring System (CVSS) angewandt. Der CVSS-Standard ermöglicht es, potenzielle oder tatsächliche Sicherheitslücken auf Basis verschiedener Kriterien miteinander zu vergleichen, um Gegenmaßnahmen besser priorisieren zu können. Für die Schweregrade einer Schwachstelle werden die Attribute "keine", "niedrig", "mittel", "hoch" und "kritisch" verwendet. Der Base Score bewertet die Voraussetzungen für einen Angriff (u.a. Authentifizierung, Komplexität, Privilegien, Userinteraktion) sowie dessen Konsequenzen. Der Temporal Score berücksichtigt darüber hinaus zeitliche Veränderungen hinsichtlich der Gefahrenlage. Das Risiko der aktuellen Schwachstelle wird nach dem CVSS mit einem Base Score von 3,9 als "niedrig" eingeschätzt.

vim Bug: Beschreibung des Angriffs

Vim (Vi IMproved) ist eine Weiterentwicklung des Texteditors vi.

Ein Angreifer kann mehrere Schwachstellen in vim ausnutzen, um beliebigen Programmcode auszuführen oder einen Denial of Service Zustand herbeizuführen.

Klassifiziert wurden die Schwachstellen mithilfe des CVE-Bezeichnungssystems (Common Vulnerabilities and Exposures) durch die individuellen Seriennummern CVE-2023-48237, CVE-2023-48236, CVE-2023-48235, CVE-2023-48234, CVE-2023-48233, CVE-2023-48232 und CVE-2023-48231.

Von der vim-Sicherheitslücke betroffene Systeme im Überblick

Betriebssysteme
UNIX, Linux, MacOS X, Windows

Produkte
Amazon Linux 2 (cpe:/o:amazon:linux_2)
Fedora Linux (cpe:/o:fedoraproject:fedora)
Ubuntu Linux (cpe:/o:canonical:ubuntu_linux)
Open Source vim < 9.0.2112 (cpe:/a:vim:vim)

Allgemeine Empfehlungen zum Umgang mit IT-Sicherheitslücken

  1. Anwender der betroffenen Systeme sollten diese auf dem aktuellsten Stand halten. Hersteller sind bei Bekanntwerden von Sicherheitslücken dazu angehalten, diese schnellstmöglich durch Entwicklung eines Patches oder eines Workarounds zu beheben. Sollten neue Sicherheitsupdates verfügbar sein, installieren Sie diese zeitnah.
  2. Konsultieren Sie zu Informationszwecken die im nächsten Abschnitt aufgeführten Quellen. Häufig enthalten diese weiterführende Informationen zur aktuellsten Version der betreffenden Software sowie zur Verfügbarkeit von Sicherheitspatches oder Hinweise zu Workarounds.
  3. Wenden Sie sich bei weiteren Fragen oder Unsicherheiten an Ihren zuständigen Administrator. IT-Sicherheitsverantwortliche sollten die genannten Quellen regelmäßig daraufhin prüfen, ob ein neues Sicherheitsupdate zur Verfügung steht.

Quellen zu Updates, Patches und Workarounds

An dieser Stelle finden Sie weiterführende Links mit Informationen über Bug-Reports, Security-Fixes und Workarounds.

Amazon Linux Security Advisory ALAS-2024-1902 vom 2024-01-09 (09.01.2024)
Weitere Informationen finden Sie unter: https://alas.aws.amazon.com/ALAS-2024-1902.html

Ubuntu Security Notice USN-6557-1 vom 2023-12-14 (15.12.2023)
Weitere Informationen finden Sie unter: https://ubuntu.com/security/notices/USN-6557-1

Amazon Linux Security Advisory ALAS-2023-2353 vom 2023-12-05 (05.12.2023)
Weitere Informationen finden Sie unter: https://alas.aws.amazon.com/AL2/ALAS-2023-2353.html

Fedora Security Advisory FEDORA-2023-45CF2B4014 vom 2023-11-22 (23.11.2023)
Weitere Informationen finden Sie unter: https://bodhi.fedoraproject.org/updates/FEDORA-2023-45cf2b4014

Fedora Security Advisory FEDORA-2023-CE3F7D4818 vom 2023-11-22 (23.11.2023)
Weitere Informationen finden Sie unter: https://bodhi.fedoraproject.org/updates/FEDORA-2023-ce3f7d4818

Fedora Security Advisory FEDORA-2023-EEC2CDB7ED vom 2023-11-22 (23.11.2023)
Weitere Informationen finden Sie unter: https://bodhi.fedoraproject.org/updates/FEDORA-2023-eec2cdb7ed

Mailing list OSS Security vom 2023-11-16 (17.11.2023)
Weitere Informationen finden Sie unter: https://seclists.org/oss-sec/2023/q4/218

Versionshistorie dieser Sicherheitswarnung

Dies ist die 5. Version des vorliegenden IT-Sicherheitshinweises für vim. Bei Bekanntgabe weiterer Updates wird dieser Text aktualisiert. Änderungen oder Ergänzungen können Sie in dieser Versionshistorie nachlesen.

17.11.2023 - Initiale Fassung
23.11.2023 - Neue Updates von Fedora aufgenommen
05.12.2023 - Neue Updates von Amazon aufgenommen
15.12.2023 - Neue Updates von Ubuntu aufgenommen
09.01.2024 - Neue Updates von Amazon aufgenommen

+++ Redaktioneller Hinweis: Dieser Text wurde auf Basis aktueller BSI-Daten KI-gestützt erstellt. Feedback und Anmerkungen nehmen wir unter hinweis@news.de entgegen. +++

Folgen Sie News.de schon bei Facebook, Twitter, Pinterest und YouTube? Hier finden Sie brandheiße News, aktuelle Videos und den direkten Draht zur Redaktion.

Bearbeitet durch kns

roj/news.de

Themen:
Bleiben Sie dran!

Wollen Sie wissen, wie das Thema weitergeht? Wir informieren Sie gerne.