Erstellt von - Uhr

Angular: Schwachstelle ermöglicht Cross-Site Scripting

Für Angular wurde ein Update zur IT-Sicherheitswarnung einer bekannten Schwachstelle veröffentlicht. Welche Betriebssysteme und Produkte von der Sicherheitslücke betroffen sind, lesen Sie hier auf news.de.

Aktuelle IT-Sicherheitshinweise auf news.de (Symbolbild). (Foto) Suche
Aktuelle IT-Sicherheitshinweise auf news.de (Symbolbild). Bild: Adobe Stock / WhataWin

Das Bundesamt für Sicherheit in der Informationstechnik (BSI) hat am 03.06.2024 ein Update zu einer am 17.07.2022 bekanntgewordenen Sicherheitslücke für Angular herausgegeben. Betroffen von der Sicherheitslücke sind die Betriebssysteme Linux, MacOS X, UNIX und Windows sowie die Produkte IBM Tivoli Business Service Manager, Open Source Angular, IBM MQ und IBM Business Automation Workflow.

Die neuesten Hersteller-Empfehlungen bezüglich Updates, Workarounds und Sicherheitspatches für diese Sicherheitslücke finden Sie hier: IBM Security Bulletin 7156277 (Stand: 03.06.2024). Weitere nützliche Links werden weiter unten in diesem Artikel aufgeführt.

Sicherheitshinweis für Angular - Risiko: mittel

Risikostufe: 3 (mittel)
CVSS Base Score: 4,2
CVSS Temporal Score: 4,0
Remoteangriff: Ja

Zur Einschätzung der Verwundbarkeit von Computersystemen wird das Common Vulnerability Scoring System (CVSS) angewandt. Der CVSS-Standard ermöglicht es, potenzielle oder tatsächliche Sicherheitslücken auf Basis verschiedener Kriterien miteinander zu vergleichen, um eine darauf aufbauende Prioritätenliste zur Einleitung von Gegenmaßnahmen zu erstellen. Für die Schweregrade einer Schwachstelle werden die Attribute "keine", "niedrig", "mittel", "hoch" und "kritisch" verwendet. Der Base Score bewertet die Voraussetzungen für einen Angriff (u.a. Authentifizierung, Komplexität, Privilegien, Userinteraktion) sowie dessen Konsequenzen. Beim Temporal Score fließen über die Zeit veränderbare Rahmenbedingungen in die Bewertung ein. Die Gefährdung der hier behandelten Schwachstelle wird nach dem CVSS mit einem Base Score von 4,2 als "mittel" eingestuft.

Angular Bug: Schwachstelle ermöglicht Cross-Site Scripting

Angular ist ein TypeScript-basiertes Front-End-Webapplikationsframework.

Ein entfernter, anonymer Angreifer kann eine Schwachstelle in Angular ausnutzen, um einen Cross-Site Scripting Angriff durchzuführen.

Klassifiziert wurde die Schwachstelle mithilfe des CVE-Referenziersystems (Common Vulnerabilities and Exposures) durch die individuelle Seriennummer CVE-2022-25869.

Von der Angular-Sicherheitslücke betroffene Systeme im Überblick

Betriebssysteme
Linux, MacOS X, UNIX, Windows

Produkte
IBM Tivoli Business Service Manager (cpe:/a:ibm:tivoli_business_service_manager)
Open Source Angular (cpe:/a:angularjs:angular.js)
IBM Tivoli Business Service Manager 6.2.0 (cpe:/a:ibm:tivoli_business_service_manager)
IBM MQ 9.1 (cpe:/a:ibm:mq)
IBM MQ 9.0 (cpe:/a:ibm:mq)
IBM MQ 9.2 (cpe:/a:ibm:mq)
IBM Business Automation Workflow (cpe:/a:ibm:business_automation_workflow)

Allgemeine Empfehlungen zum Umgang mit IT-Schwachstellen

  1. Anwender der betroffenen Anwendungen sollten diese auf dem aktuellsten Stand halten. Hersteller sind bei Bekanntwerden von Sicherheitslücken dazu angehalten, diese schnellstmöglich durch Entwicklung eines Patches oder eines Workarounds zu beheben. Sollten neue Sicherheitsupdates verfügbar sein, installieren Sie diese zeitnah.
  2. Konsultieren Sie zu Informationszwecken die im nächsten Abschnitt aufgeführten Quellen. Häufig enthalten diese weiterführende Informationen zur aktuellsten Version der betreffenden Software sowie zur Verfügbarkeit von Sicherheitspatches oder Hinweise zu Workarounds.
  3. Wenden Sie sich bei weiteren Fragen oder Unsicherheiten an Ihren zuständigen Administrator. IT-Sicherheitsverantwortliche sollten regelmäßig prüfen, wann der von der IT-Sicherheitswarnung betroffene Hersteller ein neues Sicherheitsupdate zur Verfügung stellt.

Quellen zu Updates, Patches und Workarounds

An dieser Stelle befinden sich weiterführende Links mit Informationen über Bug-Reports, Security-Fixes und Workarounds.

IBM Security Bulletin 7156277 vom 2024-06-03 (03.06.2024)
Weitere Informationen finden Sie unter: https://www.ibm.com/support/pages/node/7156277

IBM Security Bulletin 7030667 vom 2023-09-05 (05.09.2023)
Weitere Informationen finden Sie unter: https://www.ibm.com/support/pages/node/7030667

IBM Security Bulletin 7023212 vom 2023-08-09 (09.08.2023)
Weitere Informationen finden Sie unter: https://www.ibm.com/support/pages/node/7023212

IBM Security Bulletin 6839771 vom 2022-11-17 (16.11.2022)
Weitere Informationen finden Sie unter: https://www.ibm.com/blogs/psirt/security-bulletin-tivoli-business-service-manager-is-vulnerable-to-cross-site-scripting-due-to-improper-validation-in-angular-cve-2022-25869/

NIST Database vom 2022-07-17 (17.07.2022)
Weitere Informationen finden Sie unter: https://nvd.nist.gov/vuln/detail/CVE-2022-25869

Snyk.io Security Advisory vom 2022-07-17 (17.07.2022)
Weitere Informationen finden Sie unter: https://snyk.io/vuln/SNYK-JS-ANGULAR-2949781

Versionshistorie dieser Sicherheitswarnung

Dies ist die 5. Version des vorliegenden IT-Sicherheitshinweises für Angular. Bei Bekanntgabe weiterer Updates wird dieser Text aktualisiert. Änderungen oder Ergänzungen können Sie in dieser Versionshistorie nachlesen.

17.07.2022 - Initiale Fassung
16.11.2022 - Neue Updates von IBM aufgenommen
09.08.2023 - Neue Updates von IBM aufgenommen
05.09.2023 - Neue Updates von IBM aufgenommen
03.06.2024 - Neue Updates von IBM aufgenommen

+++ Redaktioneller Hinweis: Dieser Text wurde auf Basis aktueller BSI-Daten generiert und wird je nach Warnlage datengetrieben aktualisiert. Feedback und Anmerkungen nehmen wir unter hinweis@news.de entgegen. +++

Folgen Sie News.de schon bei Facebook, Twitter, Pinterest und YouTube? Hier finden Sie brandheiße News, aktuelle Videos und den direkten Draht zur Redaktion.

/roj/news.de

Themen:
Bleiben Sie dran!

Wollen Sie wissen, wie das Thema weitergeht? Wir informieren Sie gerne.