Uhr

PostgreSQL: IT-Sicherheitslücke mit hohem Risiko! Warnung erhält Update

Wie das BSI meldet, hat die IT-Sicherheitswarnung bezüglich einer bekannten Schwachstelle für PostgreSQL ein Update erhalten. Welche Betriebssysteme und Produkte von den Sicherheitslücken betroffen sind, lesen Sie hier auf news.de.

Aktuelle IT-Sicherheitshinweise auf news.de (Symbolbild). (Foto) Suche
Aktuelle IT-Sicherheitshinweise auf news.de (Symbolbild). Bild: picture alliance / dpa | Jana Pape

Das Bundesamt für Sicherheit in der Informationstechnik (BSI) hat am 25.01.2024 ein Update zu einer am 10.11.2023 bekanntgewordenen Sicherheitslücke mit mehreren Schwachstellen für PostgreSQL herausgegeben. Betroffen von der Sicherheitslücke sind die Betriebssysteme UNIX, Linux und Windows sowie die Produkte Open Source CentOS, Debian Linux, Amazon Linux 2, Red Hat Enterprise Linux, Ubuntu Linux, SUSE Linux, Oracle Linux und Open Source PostgreSQL.

Die neuesten Hersteller-Empfehlungen bezüglich Updates, Workarounds und Sicherheitspatches für diese Sicherheitslücke finden Sie hier: Amazon Linux Security Advisory ALASPOSTGRESQL14-2024-004 (Stand: 25.01.2024). Weitere nützliche Quellen werden weiter unten in diesem Artikel aufgeführt.

Mehrere Schwachstellen für PostgreSQL - Risiko: hoch

Risikostufe: 4 (hoch)
CVSS Base Score: 8,8
CVSS Temporal Score: 7,7
Remoteangriff: Ja

Zur Einschätzung der Verwundbarkeit von Computersystemen wird das Common Vulnerability Scoring System (CVSS) angewandt. Der CVSS-Standard ermöglicht es, potenzielle oder tatsächliche Sicherheitslücken auf Basis verschiedener Metriken miteinander zu vergleichen, um Gegenmaßnahmen besser priorisieren zu können. Für die Schweregrade einer Schwachstelle werden die Attribute "keine", "niedrig", "mittel", "hoch" und "kritisch" verwendet. Der Base Score bewertet die Voraussetzungen für einen Angriff (u.a. Authentifizierung, Komplexität, Privilegien, Userinteraktion) sowie dessen Konsequenzen. Der Temporal Score berücksichtigt darüber hinaus zeitliche Veränderungen hinsichtlich der Gefahrenlage. Der Schweregrad der hier behandelten Schwachstelle wird nach dem CVSS mit einem Base Score von 8,8 als "hoch" eingestuft.

PostgreSQL Bug: Beschreibung des Angriffs

PostgreSQL ist eine frei verfügbare Datenbank für unterschiedliche Betriebssysteme.

Ein entfernter, authentifizierter Angreifer kann mehrere Schwachstellen in PostgreSQL ausnutzen, um Informationen offenzulegen, beliebigen Code auszuführen oder einen Denial-of-Service-Zustand zu verursachen.

Die Verwundbarkeit wird mit den eindeutigen CVE-Identifikationsnummern (Common Vulnerabilities and Exposures) CVE-2023-5868, CVE-2023-5869 und CVE-2023-5870 gehandelt.

Von der PostgreSQL-Sicherheitslücke betroffene Systeme im Überblick

Betriebssysteme
UNIX, Linux, Windows

Produkte
Open Source CentOS (cpe:/o:centos:centos)
Debian Linux (cpe:/o:debian:debian_linux)
Amazon Linux 2 (cpe:/o:amazon:linux_2)
Red Hat Enterprise Linux (cpe:/o:redhat:enterprise_linux)
Ubuntu Linux (cpe:/o:canonical:ubuntu_linux)
SUSE Linux (cpe:/o:suse:suse_linux)
Oracle Linux (cpe:/o:oracle:linux)
Open Source PostgreSQL < 16.1 (cpe:/a:postgresql:postgresql)
Open Source PostgreSQL < 15.5 (cpe:/a:postgresql:postgresql)
Open Source PostgreSQL < 14.10 (cpe:/a:postgresql:postgresql)
Open Source PostgreSQL < 13.13 (cpe:/a:postgresql:postgresql)
Open Source PostgreSQL < 12.17 (cpe:/a:postgresql:postgresql)
Open Source PostgreSQL < 11.22 (cpe:/a:postgresql:postgresql)

Allgemeine Empfehlungen zum Umgang mit IT-Sicherheitslücken

  1. Anwender der betroffenen Anwendungen sollten diese auf dem aktuellsten Stand halten. Hersteller sind bei Bekanntwerden von Sicherheitslücken dazu angehalten, diese schnellstmöglich durch Entwicklung eines Patches oder eines Workarounds zu beheben. Sollten neue Sicherheitsupdates verfügbar sein, installieren Sie diese zeitnah.
  2. Konsultieren Sie zu Informationszwecken die im nächsten Abschnitt aufgeführten Quellen. Häufig enthalten diese weiterführende Informationen zur aktuellsten Version der betreffenden Software sowie zur Verfügbarkeit von Sicherheitspatches oder Hinweise zu Workarounds.
  3. Wenden Sie sich bei weiteren Fragen oder Unsicherheiten an Ihren zuständigen Administrator. IT-Sicherheitsverantwortliche sollten regelmäßig prüfen, wann das herstellende Unternehmen ein neues Sicherheitsupdate zur Verfügung stellt.

Quellen zu Updates, Patches und Workarounds

An dieser Stelle befinden sich weiterführende Links mit Informationen über Bug-Reports, Security-Fixes und Workarounds.

Amazon Linux Security Advisory ALASPOSTGRESQL14-2024-004 vom 2024-01-25 (25.01.2024)
Weitere Informationen finden Sie unter: https://alas.aws.amazon.com/AL2/ALASPOSTGRESQL14-2024-004.html

Amazon Linux Security Advisory ALASPOSTGRESQL12-2024-007 vom 2024-01-24 (25.01.2024)
Weitere Informationen finden Sie unter: https://alas.aws.amazon.com/AL2/ALASPOSTGRESQL12-2024-007.html

Amazon Linux Security Advisory ALASPOSTGRESQL14-2024-005 vom 2024-01-25 (25.01.2024)
Weitere Informationen finden Sie unter: https://alas.aws.amazon.com/AL2/ALASPOSTGRESQL14-2024-005.html

Amazon Linux Security Advisory ALASPOSTGRESQL13-2024-005 vom 2024-01-24 (25.01.2024)
Weitere Informationen finden Sie unter: https://alas.aws.amazon.com/AL2/ALASPOSTGRESQL13-2024-005.html

Red Hat Security Advisory RHSA-2024:0337 vom 2024-01-24 (24.01.2024)
Weitere Informationen finden Sie unter: https://access.redhat.com/errata/RHSA-2024:0337

Red Hat Security Advisory RHSA-2024:0332 vom 2024-01-23 (23.01.2024)
Weitere Informationen finden Sie unter: https://access.redhat.com/errata/RHSA-2024:0332

Ubuntu Security Notice USN-6538-2 vom 2024-01-17 (17.01.2024)
Weitere Informationen finden Sie unter: https://ubuntu.com/security/notices/USN-6538-2

SUSE Security Update SUSE-SU-2024:0106-1 vom 2024-01-15 (16.01.2024)
Weitere Informationen finden Sie unter: https://lists.suse.com/pipermail/sle-security-updates/2024-January/017657.html

CentOS Security Advisory CESA-2023:7783 vom 2024-01-12 (15.01.2024)
Weitere Informationen finden Sie unter: https://lists.centos.org/pipermail/centos-announce/2024-January/099178.html

Amazon Linux Security Advisory ALASPOSTGRESQL12-2024-006 vom 2024-01-09 (10.01.2024)
Weitere Informationen finden Sie unter: https://alas.aws.amazon.com/AL2/ALASPOSTGRESQL12-2024-006.html

Ubuntu Security Notice USN-6570-1 vom 2024-01-09 (10.01.2024)
Weitere Informationen finden Sie unter: https://ubuntu.com/security/notices/USN-6570-1

Oracle Linux Security Advisory ELSA-2023-7884 vom 2023-12-21 (22.12.2023)
Weitere Informationen finden Sie unter: https://linux.oracle.com/errata/ELSA-2023-7884.html

Red Hat Security Advisory RHSA-2023:7883 vom 2023-12-20 (21.12.2023)
Weitere Informationen finden Sie unter: https://access.redhat.com/errata/RHSA-2023:7883

Red Hat Security Advisory RHSA-2023:7885 vom 2023-12-20 (21.12.2023)
Weitere Informationen finden Sie unter: https://access.redhat.com/errata/RHSA-2023:7885

Red Hat Security Advisory RHSA-2023:7884 vom 2023-12-20 (21.12.2023)
Weitere Informationen finden Sie unter: https://access.redhat.com/errata/RHSA-2023:7884

Oracle Linux Security Advisory ELSA-2023-7790 vom 2023-12-19 (20.12.2023)
Weitere Informationen finden Sie unter: https://linux.oracle.com/errata/ELSA-2023-7790.html

Oracle Linux Security Advisory ELSA-2023-7714 vom 2023-12-19 (20.12.2023)
Weitere Informationen finden Sie unter: https://linux.oracle.com/errata/ELSA-2023-7714.html

Red Hat Security Advisory RHSA-2023:7878 vom 2023-12-19 (19.12.2023)
Weitere Informationen finden Sie unter: https://access.redhat.com/errata/RHSA-2023:7878

Oracle Linux Security Advisory ELSA-2023-7784 vom 2023-12-15 (18.12.2023)
Weitere Informationen finden Sie unter: http://linux.oracle.com/errata/ELSA-2023-7784.html

Oracle Linux Security Advisory ELSA-2023-7785 vom 2023-12-14 (15.12.2023)
Weitere Informationen finden Sie unter: https://linux.oracle.com/errata/ELSA-2023-7785.html

Red Hat Security Advisory RHSA-2023:7778 vom 2023-12-13 (14.12.2023)
Weitere Informationen finden Sie unter: https://access.redhat.com/errata/RHSA-2023:7778

Red Hat Security Advisory RHSA-2023:7785 vom 2023-12-14 (14.12.2023)
Weitere Informationen finden Sie unter: https://access.redhat.com/errata/RHSA-2023:7785

Red Hat Security Advisory RHSA-2023:7783 vom 2023-12-13 (14.12.2023)
Weitere Informationen finden Sie unter: https://access.redhat.com/errata/RHSA-2023:7783

Red Hat Security Advisory RHSA-2023:7784 vom 2023-12-14 (14.12.2023)
Weitere Informationen finden Sie unter: https://access.redhat.com/errata/RHSA-2023:7784

Red Hat Security Advisory RHSA-2023:7786 vom 2023-12-14 (14.12.2023)
Weitere Informationen finden Sie unter: https://access.redhat.com/errata/RHSA-2023:7786

Red Hat Security Advisory RHSA-2023:7789 vom 2023-12-14 (14.12.2023)
Weitere Informationen finden Sie unter: https://access.redhat.com/errata/RHSA-2023:7789

Red Hat Security Advisory RHSA-2023:7788 vom 2023-12-14 (14.12.2023)
Weitere Informationen finden Sie unter: https://access.redhat.com/errata/RHSA-2023:7788

Red Hat Security Advisory RHSA-2023:7790 vom 2023-12-14 (14.12.2023)
Weitere Informationen finden Sie unter: https://access.redhat.com/errata/RHSA-2023:7790

Oracle Linux Security Advisory ELSA-2023-7783 vom 2023-12-14 (14.12.2023)
Weitere Informationen finden Sie unter: https://linux.oracle.com/errata/ELSA-2023-7783.html

Red Hat Security Advisory RHSA-2023:7770 vom 2023-12-13 (13.12.2023)
Weitere Informationen finden Sie unter: http://access.redhat.com/errata/RHSA-2023:7770

Red Hat Security Advisory RHSA-2023:7771 vom 2023-12-13 (13.12.2023)
Weitere Informationen finden Sie unter: http://access.redhat.com/errata/RHSA-2023:7771

Red Hat Security Advisory RHSA-2023:7772 vom 2023-12-13 (13.12.2023)
Weitere Informationen finden Sie unter: http://access.redhat.com/errata/RHSA-2023:7772

Red Hat Security Advisory RHSA-2023:7714 vom 2023-12-11 (12.12.2023)
Weitere Informationen finden Sie unter: https://access.redhat.com/errata/RHSA-2023:7714

Red Hat Security Advisory RHSA-2023:7695 vom 2023-12-07 (07.12.2023)
Weitere Informationen finden Sie unter: https://access.redhat.com/errata/RHSA-2023:7695

Red Hat Security Advisory RHSA-2023:7694 vom 2023-12-07 (07.12.2023)
Weitere Informationen finden Sie unter: https://access.redhat.com/errata/RHSA-2023:7694

Ubuntu Security Notice USN-6538-1 vom 2023-12-06 (07.12.2023)
Weitere Informationen finden Sie unter: https://ubuntu.com/security/notices/USN-6538-1

Red Hat Security Advisory RHSA-2023:7667 vom 2023-12-06 (07.12.2023)
Weitere Informationen finden Sie unter: https://access.redhat.com/errata/RHSA-2023:7667

Red Hat Security Advisory RHSA-2023:7666 vom 2023-12-06 (07.12.2023)
Weitere Informationen finden Sie unter: https://access.redhat.com/errata/RHSA-2023:7666

Red Hat Security Advisory RHSA-2023:7656 vom 2023-12-06 (06.12.2023)
Weitere Informationen finden Sie unter: https://access.redhat.com/errata/RHSA-2023:7656

Oracle Linux Security Advisory ELSA-2023-7581 vom 2023-12-01 (04.12.2023)
Weitere Informationen finden Sie unter: https://linux.oracle.com/errata/ELSA-2023-7581.html

Red Hat Security Advisory RHSA-2023:7616 vom 2023-11-30 (01.12.2023)
Weitere Informationen finden Sie unter: https://access.redhat.com/errata/RHSA-2023:7616

Red Hat Security Advisory RHSA-2023:7580 vom 2023-11-29 (30.11.2023)
Weitere Informationen finden Sie unter: https://access.redhat.com/errata/RHSA-2023:7580

Red Hat Security Advisory RHSA-2023:7545 vom 2023-11-28 (29.11.2023)
Weitere Informationen finden Sie unter: https://access.redhat.com/errata/RHSA-2023:7545

SUSE Security Update SUSE-SU-2023:4495-1 vom 2023-11-21 (21.11.2023)
Weitere Informationen finden Sie unter: https://lists.suse.com/pipermail/sle-security-updates/2023-November/017129.html

SUSE Security Update SUSE-SU-2023:4479-1 vom 2023-11-20 (21.11.2023)
Weitere Informationen finden Sie unter: https://lists.suse.com/pipermail/sle-security-updates/2023-November/017120.html

SUSE Security Update SUSE-SU-2023:4454-1 vom 2023-11-16 (16.11.2023)
Weitere Informationen finden Sie unter: https://lists.suse.com/pipermail/sle-security-updates/2023-November/017045.html

SUSE Security Update SUSE-SU-2023:4455-1 vom 2023-11-16 (16.11.2023)
Weitere Informationen finden Sie unter: https://lists.suse.com/pipermail/sle-security-updates/2023-November/017044.html

SUSE Security Update SUSE-SU-2023:4433-1 vom 2023-11-14 (15.11.2023)
Weitere Informationen finden Sie unter: https://lists.suse.com/pipermail/sle-security-updates/2023-November/017033.html

Debian Security Advisory DLA-3651 vom 2023-11-14 (15.11.2023)
Weitere Informationen finden Sie unter: https://lists.debian.org/debian-lts-announce/2023/11/msg00007.html

SUSE Security Update SUSE-SU-2023:4434-1 vom 2023-11-14 (15.11.2023)
Weitere Informationen finden Sie unter: https://lists.suse.com/pipermail/sle-security-updates/2023-November/017032.html

Debian Security Advisory DSA-5554 vom 2023-11-13 (14.11.2023)
Weitere Informationen finden Sie unter: https://lists.debian.org/debian-security-announce/2023/msg00250.html

SUSE Security Update SUSE-SU-2023:4418-1 vom 2023-11-13 (14.11.2023)
Weitere Informationen finden Sie unter: https://lists.suse.com/pipermail/sle-security-updates/2023-November/017019.html

SUSE Security Update SUSE-SU-2023:4425-1 vom 2023-11-13 (14.11.2023)
Weitere Informationen finden Sie unter: https://lists.suse.com/pipermail/sle-security-updates/2023-November/017022.html

Debian Security Advisory DSA-5553 vom 2023-11-13 (14.11.2023)
Weitere Informationen finden Sie unter: https://lists.debian.org/debian-security-announce/2023/msg00249.html

PostgreSQL Security Advisory vom 2023-11-09 (10.11.2023)
Weitere Informationen finden Sie unter: https://www.postgresql.org/support/security/CVE-2023-5870/

PostgreSQL Security Advisory vom 2023-11-09 (10.11.2023)
Weitere Informationen finden Sie unter: https://www.postgresql.org/support/security/CVE-2023-5869/

PostgreSQL Security Advisory vom 2023-11-09 (10.11.2023)
Weitere Informationen finden Sie unter: https://www.postgresql.org/support/security/CVE-2023-5868/

PostgreSQL News vom 2023-11-09 (10.11.2023)
Weitere Informationen finden Sie unter: https://www.postgresql.org/about/news/postgresql-161-155-1410-1313-1217-and-1122-released-2749/

Versionshistorie dieser Sicherheitswarnung

Dies ist die 27. Version des vorliegenden IT-Sicherheitshinweises für PostgreSQL. Bei Bekanntgabe weiterer Updates wird dieser Text aktualisiert. Änderungen oder Ergänzungen können Sie in dieser Versionshistorie nachlesen.

10.11.2023 - Initiale Fassung
14.11.2023 - Neue Updates von Debian und SUSE aufgenommen
15.11.2023 - Neue Updates von SUSE und Debian aufgenommen
16.11.2023 - Neue Updates von SUSE aufgenommen
21.11.2023 - Neue Updates von SUSE aufgenommen
29.11.2023 - Neue Updates von Red Hat aufgenommen
30.11.2023 - Neue Updates von Red Hat aufgenommen
01.12.2023 - Neue Updates von Red Hat aufgenommen
04.12.2023 - Neue Updates von Oracle Linux aufgenommen
06.12.2023 - Neue Updates von Red Hat aufgenommen
07.12.2023 - Neue Updates von Red Hat und Ubuntu aufgenommen
12.12.2023 - Neue Updates von Red Hat aufgenommen
13.12.2023 - Neue Updates von Red Hat aufgenommen
14.12.2023 - Neue Updates von Oracle Linux und Red Hat aufgenommen
15.12.2023 - Neue Updates von Oracle Linux aufgenommen
18.12.2023 - Neue Updates von Oracle Linux aufgenommen
19.12.2023 - Neue Updates von Red Hat aufgenommen
20.12.2023 - Neue Updates von Oracle Linux aufgenommen
21.12.2023 - Neue Updates von Red Hat aufgenommen
22.12.2023 - Neue Updates von Oracle Linux aufgenommen
10.01.2024 - Neue Updates von Ubuntu und Amazon aufgenommen
15.01.2024 - Neue Updates von CentOS aufgenommen
16.01.2024 - Neue Updates von SUSE aufgenommen
17.01.2024 - Neue Updates von Ubuntu aufgenommen
23.01.2024 - Neue Updates von Red Hat aufgenommen
24.01.2024 - Neue Updates von Red Hat aufgenommen
25.01.2024 - Neue Updates von Amazon aufgenommen

+++ Redaktioneller Hinweis: Dieser Text wurde auf Basis aktueller BSI-Daten generiert und wird je nach Warnlage datengetrieben aktualisiert. Feedback und Anmerkungen nehmen wir unter hinweis@news.de entgegen. +++

Folgen Sie News.de schon bei Facebook, Twitter, Pinterest und YouTube? Hier finden Sie brandheiße News, aktuelle Videos und den direkten Draht zur Redaktion.

Bearbeitet durch kns

roj/news.de

Themen:
Bleiben Sie dran!

Wollen Sie wissen, wie das Thema weitergeht? Wir informieren Sie gerne.