Uhr

gcc: Schwachstelle ermöglicht Manipulation von Daten

Für gcc liegt eine IT-Sicherheitswarnung vor. Um welche Schwachstelle es sich handelt, welche Produkte betroffen sind und was Sie tun können, erfahren Sie hier.

Aktuelle IT-Sicherheitshinweise auf news.de (Symbolbild). (Foto) Suche
Aktuelle IT-Sicherheitshinweise auf news.de (Symbolbild). Bild: picture alliance/dpa | Oliver Berg

Das Bundesamt für Sicherheit in der Informationstechnik (BSI) hat am 09.12.2022 ein Update zu einer am 27.07.2017 bekanntgewordenen Sicherheitslücke für gcc veröffentlicht. Betroffen von der Sicherheitslücke sind das Betriebssystem Linux sowie die Produkte Red Hat Enterprise Linux, Ubuntu Linux, SUSE Linux und Open Source gcc.

Die neuesten Hersteller-Empfehlungen bezüglich Updates, Workarounds und Sicherheitspatches für diese Sicherheitslücke finden Sie hier: Ubuntu Security Notice USN-5770-1 (Stand: 08.12.2022). Weitere nützliche Links werden weiter unten in diesem Artikel aufgeführt.

Sicherheitshinweis für gcc - Risiko: mittel

Risikostufe: 4 (mittel)
CVSS Base Score: 7,3
CVSS Temporal Score: 6,4
Remoteangriff: Ja

Zur Bewertung des Schweregrads von Sicherheitsanfälligkeiten in Computersystemen wird das Common Vulnerability Scoring System (CVSS) angewandt. Der CVSS-Standard ermöglicht es, potenzielle oder tatsächliche Sicherheitslücken auf Basis verschiedener Metriken miteinander zu vergleichen, um Gegenmaßnahmen besser priorisieren zu können. Für die Schweregrade einer Schwachstelle werden die Attribute "keine", "niedrig", "mittel", "hoch" und "kritisch" verwendet. Der Base Score bewertet die Voraussetzungen für einen Angriff (u.a. Authentifizierung, Komplexität, Privilegien, Userinteraktion) sowie dessen Konsequenzen. Beim Temporal Score fließen über die Zeit veränderbare Rahmenbedingungen in die Bewertung ein. Der Schweregrad der hier behandelten Schwachstelle wird nach dem CVSS mit einem Base Score von 7,3 als "mittel" eingestuft.

gcc Bug: Schwachstelle ermöglicht Manipulation von Daten

Die GNU Compiler Collection (GCC) ist eine Compiler-Suite des GNU-Projekts.

Ein entfernter, anonymer Angreifer kann eine Schwachstelle in gcc ausnutzen, um Daten zu manipulieren und möglicherweise seine Privilegien zu erweitern.

Klassifiziert wurde die Schwachstelle mithilfe des CVE-Referenziersystems (Common Vulnerabilities and Exposures) durch die individuelle Seriennummer CVE-2017-11671.

Von der gcc-Sicherheitslücke betroffene Systeme im Überblick

Betriebssystem
Linux

Produkte
Red Hat Enterprise Linux (cpe:/o:redhat:enterprise_linux)
Ubuntu Linux (cpe:/o:canonical:ubuntu_linux)
SUSE Linux (cpe:/o:suse:suse_linux)
Open Source gcc 4.6 (cpe:/a:gnu:gcc)
Open Source gcc 4.7 (cpe:/a:gnu:gcc)
Open Source gcc 4.8 (cpe:/a:gnu:gcc)
Open Source gcc 4.9 (cpe:/a:gnu:gcc)
Open Source gcc 5 - 5.4 (cpe:/a:gnu:gcc)
Open Source gcc 6 - 6.3 (cpe:/a:gnu:gcc)

Allgemeine Empfehlungen zum Umgang mit IT-Schwachstellen

  1. Anwender der betroffenen Systeme sollten diese auf dem aktuellsten Stand halten. Hersteller sind bei Bekanntwerden von Sicherheitslücken dazu angehalten, diese schnellstmöglich durch Entwicklung eines Patches oder eines Workarounds zu beheben. Sollten neue Sicherheitsupdates verfügbar sein, installieren Sie diese zeitnah.

  2. Konsultieren Sie zu Informationszwecken die im nächsten Abschnitt aufgeführten Quellen. Häufig enthalten diese weiterführende Informationen zur aktuellsten Version der betreffenden Software sowie zur Verfügbarkeit von Sicherheitspatches oder Hinweise zu Workarounds.

  3. Wenden Sie sich bei weiteren Fragen oder Unsicherheiten an Ihren zuständigen Administrator. IT-Sicherheitsverantwortliche sollten die genannten Quellen regelmäßig daraufhin prüfen, ob ein neues Sicherheitsupdate zur Verfügung steht.

Quellen zu Updates, Patches und Workarounds

An dieser Stelle befinden sich weiterführende Links mit Informationen über Bug-Reports, Security-Fixes und Workarounds.

Ubuntu Security Notice USN-5770-1 vom 2022-12-08 (09.12.2022)
Weitere Informationen finden Sie unter: https://ubuntu.com/security/notices/USN-5770-1

Red Hat Security Advisory RHSA-2018:0849 vom 2018-04-11 (11.04.2018)
Weitere Informationen finden Sie unter: https://access.redhat.com/errata/RHSA-2018:0849

SUSE Security Update SUSE-SU-2017:2526-1 vom 2017-09-20 (20.09.2017)
Weitere Informationen finden Sie unter: https://www.suse.com/support/update/announcement/2017/suse-su-20172526-1.html

SUSE Security Update SUSE-SU-2017:2380-1 vom 2017-09-06 (07.09.2017)
Weitere Informationen finden Sie unter: https://www.suse.com/support/update/announcement/2017/suse-su-20172380-1.html

National Vulnerability Database CVE-2017-11671 vom 2017-07-26 (27.07.2017)
Weitere Informationen finden Sie unter: https://nvd.nist.gov/vuln/detail/CVE-2017-11671

Versionshistorie dieser Sicherheitswarnung

Dies ist die 6. Version des vorliegenden IT-Sicherheitshinweises für gcc. Sollten weitere Updates bekanntgegeben werden, wird dieser Text aktualisiert. Änderungen oder Ergänzungen können Sie in dieser Versionshistorie nachlesen.

09.12.2022 - Neue Updates von Ubuntu aufgenommen
27.07.2017 - Initial Release
07.09.2017 - New remediations available
20.09.2017 - New remediations available
11.04.2018 - New remediations available
31.07.2017 - Added references

+++ Redaktioneller Hinweis: Dieser Text wurde auf Basis aktueller BSI-Daten KI-gestützt erstellt. Feedback und Anmerkungen nehmen wir unter hinweis@news.de entgegen. +++

Folgen Sie News.de schon bei Facebook, Twitter, Pinterest und YouTube? Hier finden Sie brandheiße News, aktuelle Videos und den direkten Draht zur Redaktion.

roj/news.de

Themen:
Bleiben Sie dran!

Wollen Sie wissen, wie das Thema weitergeht? Wir informieren Sie gerne.