Uhr

Ruby gefährdet: Update für IT-Sicherheitswarnung (Risiko: hoch)

Eine für Ruby herausgegebene Sicherheitswarnung hat vom BSI ein Update erhalten. Eine Beschreibung der Sicherheitslücke inklusive der neuesten Updates sowie Infos zu betroffenen Betriebssystemen und Produkten lesen Sie hier.

Aktuelle IT-Sicherheitshinweise auf news.de (Symbolbild). (Foto) Suche
Aktuelle IT-Sicherheitshinweise auf news.de (Symbolbild). Bild: picture alliance / dpa | Jana Pape

Das Bundesamt für Sicherheit in der Informationstechnik (BSI) hat am 25.01.2023 ein Update zu einer am 25.11.2022 bekanntgewordenen Sicherheitslücke für Ruby herausgegeben. Betroffen von der Sicherheitslücke sind die Betriebssysteme UNIX, Linux, MacOS X und Windows sowie die Produkte Amazon Linux 2, Ubuntu Linux und Open Source Ruby.

Die neuesten Hersteller-Empfehlungen bezüglich Updates, Workarounds und Sicherheitspatches für diese Sicherheitslücke finden Sie hier: Amazon Linux Security Advisory ALAS-2023-262 (Stand: 25.01.2023). Weitere nützliche Quellen werden weiter unten in diesem Artikel aufgeführt.

Sicherheitshinweis für Ruby - Risiko: hoch

Risikostufe: 3 (hoch)
CVSS Base Score: 9,1
CVSS Temporal Score: 7,9
Remoteangriff: Ja

Zur Bewertung des Schweregrads von Schwachstellen in Computersystemen wird das Common Vulnerability Scoring System (CVSS) angewandt. Der CVSS-Standard ermöglicht es, potenzielle oder tatsächliche Sicherheitslücken auf Basis verschiedener Metriken miteinander zu vergleichen, um Gegenmaßnahmen besser priorisieren zu können. Für die Schweregrade einer Schwachstelle werden die Attribute "keine", "niedrig", "mittel", "hoch" und "kritisch" verwendet. Der Base Score bewertet die Voraussetzungen für einen Angriff (u.a. Authentifizierung, Komplexität, Privilegien, Userinteraktion) sowie dessen Konsequenzen. Der Temporal Score berücksichtigt darüber hinaus zeitliche Veränderungen hinsichtlich der Gefahrenlage. Das Risiko der aktuellen Schwachstelle wird nach dem CVSS mit einem Base Score von 9,1 als "hoch" eingestuft.

Ruby Bug: Schwachstelle ermöglicht Manipulation von Dateien

Ruby ist eine interpretierte, objektorientierte Skriptsprache.

Ein entfernter, anonymer Angreifer kann eine Schwachstelle in Ruby ausnutzen, um Dateien zu manipulieren.

Die Verwundbarkeit wird mit der eindeutigen CVE-Identifikationsnummer (Common Vulnerabilities and Exposures) CVE-2021-33621 gehandelt.

Von der Ruby-Sicherheitslücke betroffene Systeme im Überblick

Betriebssysteme
UNIX, Linux, MacOS X, Windows

Produkte
Amazon Linux 2 (cpe:/o:amazon:linux_2)
Ubuntu Linux (cpe:/o:canonical:ubuntu_linux)
Open Source Ruby < 2.7.7 (cpe:/a:ruby-lang:ruby)
Open Source Ruby < 3.0.5 (cpe:/a:ruby-lang:ruby)
Open Source Ruby < 3.1.3 (cpe:/a:ruby-lang:ruby)

Allgemeine Empfehlungen zum Umgang mit IT-Sicherheitslücken

  1. Anwender der betroffenen Anwendungen sollten diese auf dem aktuellsten Stand halten. Hersteller sind bei Bekanntwerden von Sicherheitslücken dazu angehalten, diese schnellstmöglich durch Entwicklung eines Patches oder eines Workarounds zu beheben. Sollten neue Sicherheitsupdates verfügbar sein, installieren Sie diese zeitnah.

  2. Konsultieren Sie zu Informationszwecken die im nächsten Abschnitt aufgeführten Quellen. Häufig enthalten diese weiterführende Informationen zur aktuellsten Version der betreffenden Software sowie zur Verfügbarkeit von Sicherheitspatches oder Hinweise zu Workarounds.

  3. Wenden Sie sich bei weiteren Fragen oder Unsicherheiten an Ihren zuständigen Administrator. IT-Sicherheitsverantwortliche sollten die genannten Quellen regelmäßig daraufhin prüfen, ob ein neues Sicherheitsupdate zur Verfügung steht.

Hersteller-Informationen zu Updates, Patches und Workarounds

An dieser Stelle finden Sie weiterführende Links mit Informationen über Bug-Reports, Security-Fixes und Workarounds.

Amazon Linux Security Advisory ALAS-2023-262 vom 2023-01-25 (25.01.2023)
Weitere Informationen finden Sie unter: https://alas.aws.amazon.com/AL2022/ALAS-2023-262.html

Ubuntu Security Notice USN-5806-2 vom 2023-01-23 (24.01.2023)
Weitere Informationen finden Sie unter: https://ubuntu.com/security/notices/USN-5806-2

Ubuntu Security Notice USN-5806-1 vom 2023-01-17 (18.01.2023)
Weitere Informationen finden Sie unter: https://ubuntu.com/security/notices/USN-5806-1

Ruby Release Notes vom 2022-11-24 (25.11.2022)
Weitere Informationen finden Sie unter: https://www.ruby-lang.org/en/news/2022/11/24/ruby-2-7-7-released/

Ruby Release Notes vom 2022-11-24 (25.11.2022)
Weitere Informationen finden Sie unter: https://www.ruby-lang.org/en/news/2022/11/24/ruby-3-0-5-released/

Ruby Release Notes vom 2022-11-24 (25.11.2022)
Weitere Informationen finden Sie unter: https://www.ruby-lang.org/en/news/2022/11/24/ruby-3-1-3-released/

Versionshistorie dieser Sicherheitswarnung

Dies ist die 5. Version des vorliegenden IT-Sicherheitshinweises für Ruby. Bei Bekanntgabe weiterer Updates wird dieser Text aktualisiert. Die vorgenommenen Änderungen können Sie anhand der folgenden Versionshistorie nachvollziehen.

25.11.2022 - Initiale Fassung
01.12.2022 - Referenz(en) aufgenommen: FEDORA-2022-B9B710F199, FEDORA-2022-EF96A58BBE, FEDORA-2022-F0F6C6BEC2
18.01.2023 - Neue Updates von Ubuntu aufgenommen
24.01.2023 - Neue Updates von Ubuntu aufgenommen
25.01.2023 - Neue Updates von Amazon aufgenommen

+++ Redaktioneller Hinweis: Dieser Text wurde auf Basis aktueller BSI-Daten KI-gestützt erstellt. Feedback und Anmerkungen nehmen wir unter hinweis@news.de entgegen. +++

Folgen Sie News.de schon bei Facebook, Twitter, Pinterest und YouTube? Hier finden Sie brandheiße News, aktuelle Videos und den direkten Draht zur Redaktion.

roj/news.de

Themen:
Bleiben Sie dran!

Wollen Sie wissen, wie das Thema weitergeht? Wir informieren Sie gerne.