Uhr

vim gefährdet: IT-Sicherheitslücke mit hohem Risiko! Mehrere Schwachstellen gemeldet

Wie das BSI meldet, sind für vim Schwachstellen festgestellt worden. Welche Betriebssysteme und Produkte von den Sicherheitslücken betroffen sind, lesen Sie hier auf news.de.

Aktuelle IT-Sicherheitshinweise auf news.de (Symbolbild). (Foto) Suche
Aktuelle IT-Sicherheitshinweise auf news.de (Symbolbild). Bild: Adobe Stock / andriano_cz

Das Bundesamt für Sicherheit in der Informationstechnik (BSI) hat am 27.12.2022 ein Update zu einer am 20.05.2022 bekanntgewordenen Sicherheitslücke mit mehreren Schwachstellen für vim veröffentlicht. Betroffen von der Sicherheitslücke sind die Betriebssysteme Linux, MacOS X und Windows sowie die Produkte Debian Linux, Amazon Linux 2, Red Hat Enterprise Linux, Ubuntu Linux, SUSE Linux, Oracle Linux, Red Hat OpenShift, Gentoo Linux, Avaya Aura Communication Manager, Avaya Aura Session Manager, Avaya Aura Application Enablement Services, Avaya Aura System Manager, Avaya Aura Experience Portal und Open Source vim.

Die neuesten Hersteller-Empfehlungen bezüglich Updates, Workarounds und Sicherheitspatches für diese Sicherheitslücke finden Sie hier: SUSE Security Update SUSE-SU-2022:4619-1 (Stand: 27.12.2022). Weitere nützliche Links werden weiter unten in diesem Artikel aufgeführt.

Mehrere Schwachstellen für vim - Risiko: hoch

Risikostufe: 4 (hoch)
CVSS Base Score: 9,6
CVSS Temporal Score: 8,6
Remoteangriff: Ja

Zur Bewertung des Schweregrads von Schwachstellen in Computersystemen wird das Common Vulnerability Scoring System (CVSS) angewandt. Der CVSS-Standard ermöglicht es, potenzielle oder tatsächliche Sicherheitslücken auf Basis verschiedener Kriterien miteinander zu vergleichen, um eine darauf aufbauende Prioritätenliste zur Einleitung von Gegenmaßnahmen zu erstellen. Für die Schweregrade einer Schwachstelle werden die Attribute "keine", "niedrig", "mittel", "hoch" und "kritisch" verwendet. Der Base Score bewertet die Voraussetzungen für einen Angriff (u.a. Authentifizierung, Komplexität, Privilegien, Userinteraktion) sowie dessen Konsequenzen. Beim Temporal Score fließen über die Zeit veränderbare Rahmenbedingungen in die Bewertung ein. Der Schweregrad der aktuellen Schwachstelle wird nach dem CVSS mit einem Base Score von 9,6 als "hoch" eingeschätzt.

vim Bug: Beschreibung des Angriffs

Vim (Vi IMproved) ist eine Weiterentwicklung des Texteditors vi.

Ein entfernter, anonymer Angreifer kann mehrere Schwachstellen in vim ausnutzen, um Informationen zu manipulieren, einen Denial-of-Service-Zustand zu verursachen und beliebigen Code auszuführen.

Die Verwundbarkeit wird mit den eindeutigen CVE-Identifikationsnummern (Common Vulnerabilities and Exposures) CVE-2022-1785 und CVE-2022-1796 gehandelt.

Von der vim-Sicherheitslücke betroffene Systeme im Überblick

Betriebssysteme
Linux, MacOS X, Windows

Produkte
Debian Linux (cpe:/o:debian:debian_linux)
Amazon Linux 2 (cpe:/o:amazon:linux_2)
Red Hat Enterprise Linux (cpe:/o:redhat:enterprise_linux)
Ubuntu Linux (cpe:/o:canonical:ubuntu_linux)
SUSE Linux (cpe:/o:suse:suse_linux)
Oracle Linux (cpe:/o:oracle:linux)
Red Hat OpenShift (cpe:/a:redhat:openshift)
Gentoo Linux (cpe:/o:gentoo:linux)
Avaya Aura Communication Manager (cpe:/a:avaya:communication_manager)
Avaya Aura Session Manager (cpe:/a:avaya:session_manager)
Avaya Aura Application Enablement Services (cpe:/a:avaya:aura_application_enablement_services)
Avaya Aura System Manager (cpe:/a:avaya:aura_system_manager)
Avaya Aura Experience Portal (cpe:/a:avaya:aura_experience_portal)
Open Source vim < 8.2.4977 (cpe:/a:vim:vim)
Open Source vim < 8.2.4977 (cpe:/a:vim:vim)
Open Source vim < 8.2.4979 (cpe:/a:vim:vim)
Open Source vim < 8.2.4979 (cpe:/a:vim:vim)

Allgemeine Maßnahmen zum Umgang mit IT-Sicherheitslücken

  1. Anwender der betroffenen Systeme sollten diese auf dem aktuellsten Stand halten. Hersteller sind bei Bekanntwerden von Sicherheitslücken dazu angehalten, diese schnellstmöglich durch Entwicklung eines Patches oder eines Workarounds zu beheben. Sollten neue Sicherheitsupdates verfügbar sein, installieren Sie diese zeitnah.

  2. Konsultieren Sie zu Informationszwecken die im nächsten Abschnitt aufgeführten Quellen. Häufig enthalten diese weiterführende Informationen zur aktuellsten Version der betreffenden Software sowie zur Verfügbarkeit von Sicherheitspatches oder Hinweise zu Workarounds.

  3. Wenden Sie sich bei weiteren Fragen oder Unsicherheiten an Ihren zuständigen Administrator. IT-Sicherheitsverantwortliche sollten regelmäßig prüfen, wann das herstellende Unternehmen ein neues Sicherheitsupdate zur Verfügung stellt.

Quellen zu Updates, Patches und Workarounds

An dieser Stelle befinden sich weiterführende Links mit Informationen über Bug-Reports, Security-Fixes und Workarounds.

SUSE Security Update SUSE-SU-2022:4619-1 vom 2022-12-27 (27.12.2022)
Weitere Informationen finden Sie unter: https://lists.suse.com/pipermail/sle-security-updates/2022-December/013343.html

Red Hat Security Advisory RHSA-2022:8781 vom 2022-12-08 (08.12.2022)
Weitere Informationen finden Sie unter: https://access.redhat.com/errata/RHSA-2022:8781

Debian Security Advisory DLA-3204 vom 2022-11-24 (24.11.2022)
Weitere Informationen finden Sie unter: https://lists.debian.org/debian-lts-announce/2022/11/msg00032.html

Red Hat Security Advisory RHSA-2022:7055 vom 2022-10-19 (20.10.2022)
Weitere Informationen finden Sie unter: https://access.redhat.com/errata/RHSA-2022:7055

Red Hat Security Advisory RHSA-2022:7058 vom 2022-10-20 (20.10.2022)
Weitere Informationen finden Sie unter: https://access.redhat.com/errata/RHSA-2022:7058

Red Hat Security Advisory RHSA-2022:6182 vom 2022-09-06 (07.09.2022)
Weitere Informationen finden Sie unter: https://access.redhat.com/errata/RHSA-2022:6182

Red Hat Security Advisory RHSA-2022:6183 vom 2022-09-06 (07.09.2022)
Weitere Informationen finden Sie unter: https://access.redhat.com/errata/RHSA-2022:6183

Red Hat Security Advisory RHSA-2022:6184 vom 2022-08-25 (26.08.2022)
Weitere Informationen finden Sie unter: https://access.redhat.com/errata/RHSA-2022:6184

Gentoo Linux Security Advisory GLSA-202208-32 vom 2022-08-23 (23.08.2022)
Weitere Informationen finden Sie unter: https://security.gentoo.org/glsa/202208-32

Oracle Linux Security Advisory ELSA-2022-5942 vom 2022-08-10 (10.08.2022)
Weitere Informationen finden Sie unter: http://linux.oracle.com/errata/ELSA-2022-5942.html

Red Hat Security Advisory RHSA-2022:5942 vom 2022-08-09 (10.08.2022)
Weitere Informationen finden Sie unter: https://access.redhat.com/errata/RHSA-2022:5942

AVAYA Security Advisory ASA-2022-110 vom 2022-08-04 (08.08.2022)
Weitere Informationen finden Sie unter: https://downloads.avaya.com/css/P8/documents/101083118

Oracle Linux Security Advisory ELSA-2022-5813 vom 2022-08-05 (08.08.2022)
Weitere Informationen finden Sie unter: http://linux.oracle.com/errata/ELSA-2022-5813.html

Amazon Linux Security Advisory ALAS-2022-1628 vom 2022-08-05 (05.08.2022)
Weitere Informationen finden Sie unter: https://alas.aws.amazon.com/ALAS-2022-1628.html

Red Hat Security Advisory RHSA-2022:5813 vom 2022-08-03 (04.08.2022)
Weitere Informationen finden Sie unter: https://access.redhat.com/errata/RHSA-2022:5813

Amazon Linux Security Advisory ALAS-2022-116 vom 2022-07-21 (22.07.2022)
Weitere Informationen finden Sie unter: https://alas.aws.amazon.com/AL2022/ALAS-2022-116.html

Amazon Linux Security Advisory ALAS-2022-1829 vom 2022-07-21 (21.07.2022)
Weitere Informationen finden Sie unter: https://alas.aws.amazon.com/AL2/ALAS-2022-1829.html

Ubuntu Security Notice USN-5498-1 vom 2022-06-30 (01.07.2022)
Weitere Informationen finden Sie unter: https://ubuntu.com/security/notices/USN-5498-1

SUSE Security Update SUSE-SU-2022:2102-1 vom 2022-06-16 (17.06.2022)
Weitere Informationen finden Sie unter: https://lists.suse.com/pipermail/sle-security-updates/2022-June/011301.html

Huntr Vulnerability Description vom 2022-05-19 (20.05.2022)
Weitere Informationen finden Sie unter: https://huntr.dev/bounties/f6739b58-49f9-4056-a843-bf76bbc1253e/

Huntr Vulnerability Description vom 2022-05-19 (20.05.2022)
Weitere Informationen finden Sie unter: https://huntr.dev/bounties/8c969cba-eef2-4943-b44a-4e3089599109/

Versionshistorie dieser Sicherheitswarnung

Dies ist die 16. Version des vorliegenden IT-Sicherheitshinweises für vim. Bei Bekanntgabe weiterer Updates wird dieser Text aktualisiert. Die vorgenommenen Änderungen können Sie anhand der folgenden Versionshistorie nachvollziehen.

20.05.2022 - Initiale Fassung
17.06.2022 - Neue Updates von SUSE aufgenommen
01.07.2022 - Neue Updates von Ubuntu aufgenommen
21.07.2022 - Neue Updates von Amazon aufgenommen
22.07.2022 - Neue Updates von Amazon aufgenommen
04.08.2022 - Neue Updates von Red Hat aufgenommen
05.08.2022 - Neue Updates von Amazon aufgenommen
08.08.2022 - Neue Updates von Oracle Linux und AVAYA aufgenommen
10.08.2022 - Neue Updates von Red Hat und Oracle Linux aufgenommen
23.08.2022 - Neue Updates von Gentoo aufgenommen
26.08.2022 - Neue Updates von Red Hat aufgenommen
07.09.2022 - Neue Updates von Red Hat aufgenommen
20.10.2022 - Neue Updates von Red Hat aufgenommen
24.11.2022 - Neue Updates von Debian aufgenommen
08.12.2022 - Neue Updates von Red Hat aufgenommen
27.12.2022 - Neue Updates von SUSE aufgenommen

+++ Redaktioneller Hinweis: Dieser Text wurde auf Basis aktueller BSI-Daten KI-gestützt erstellt. Feedback und Anmerkungen nehmen wir unter hinweis@news.de entgegen. +++

Folgen Sie News.de schon bei Facebook, Twitter, Pinterest und YouTube? Hier finden Sie brandheiße News, aktuelle Videos und den direkten Draht zur Redaktion.

roj/news.de

Themen:
Bleiben Sie dran!

Wollen Sie wissen, wie das Thema weitergeht? Wir informieren Sie gerne.